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Introduction

This manual is derived from the Tutorials located on the ImageMatics web site http://www.imagematics.com .

The Tutorial link is found on the Product Page and may be accessed directly at http://www.imagematics.com/Examples/Product_Stillmotion_Examples.htm
On each example page you will find download modules that contain sample files including the resulting animations used in the examples.

Example 1 How to Make a Basic Movie
This example will show how a basic Flash Movie is created.  The Movie will be a simple pan and zoom from a wide angle shot to a close up of the man's face.  The files associated with this example may be downloaded by clicking on the download icon.  The files are contained in a self extracting .exe so simply click on the downloaded file and the test files and resulting SWF file will be loaded into your selected directory.  Click on the Download Icon to download the Example 1 files.
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Step 1 From the File Menu the Load Image selection is picked.  The image file is then selected.  Here Cornwall Couple.tga is the selected file.
Figure 1 shows the ImageMatics StillMotion Creator™ screen after the image is loaded.
Note: 
• The Camera Window covers the entire Stage.  
• The entire image is shown in the Viewer
• The Viewer Time Frame Indicator shows 00:00:00 (the start)
• A KeyFrame is inserted at the start of the Timeline and the name of the image is shown on the line
• The Timeline indicator is positioned at the load point (00:00:00)
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Step 2 The Camera Window is moved and sized to select the start image of the movie sequence to be created.  The KeyFrame Control button is clicked on the Viewer to lock the new Camera Window size and position.
Figure 2 shows ImageMatics StillMotion Creator™ screen after the start position is selected.
Note:
• The new position of the Camera Window
• The adjusted image shown in the Viewer indicating what the first frame of the motion sequence (move) will look like. 
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Step3 The length of the move in time and the image view are selected by first moving the Timeline indicator bar to the 11 second mark.  The Time Frame Indicator will show 00:11:00 when exactly positioned.  The "+" and "-" keys will let you move the Indicator in single frame increments if you need to.  The Camera Window is moved and scaled to get the desired view and then the Key Frame Control is clicked to lock in the position and the time.  A new Key Marker appears on the Timeline.  Use the Viewer controls to preview your Movie.  
Figure 3 Shows the ImageMatics StillMotion Creator™ screen after end view and time are selected.
Note:
• The image in the Viewer shows what  the end of the Movie sequence will look like
• A second KeyFrame Marker has been added at the Timeline
• The Timeline Indicator has moved one second after the KeyFrame Marker as a convenience.

Step 4 The final step is to create the Flash SWF file.  From the File Menu click on Make Flash SWF Movie.  Set the background color for white (all values 255) Leave the Frame rate at 30 and set the Quality to around 70%.  The movie shown here used 72%.  Click on OK and you will be prompted with a standard file menu to name and save your SWF file.  The Movie was saved under the name Example 1. Your done.
You can if you wish save the Show file which contains the timing and positions.  This lets you edit the Movie at a later time.  Select Save Show from the File Menu to do this.


In Example 2 we will Illustrate how to create a smooth continuous loop Movie and also how to Cut and Paste Key Markers
Example 2 How to Make a Continuous Loop Movie
In this example we will take the Movie made in Example 1 and edit using Cut and Paste of KeyFrame Markers to make a continuous loop.  The Image file (Cornwall Couple.tga), the Show File (example2.mpx) and the resulting Flash Movie (example2.swf) may be downloaded by clicking on the Download Icon.
Concept A KeyFrame Marker is an object that contains all the information about a start or end point in a Movie segment.  Copying a KeyFrame Marker copies all the information about the size and orientation of the image in the Camera Window.  To make a continuously looping Movie that does not have abrupt jumps when it repeats (like the Movie in Example 1) the Image must end in the same position that it starts.  Copying the start KeyFrame Marker  to the end of the Movie accomplishes this.  Try it, it [image: image7.jpg]=loix
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works.  We will start where we ended in Example 1.
Step 1 Here is the screen at the end of Example 1.  We will click on the first (leftmost) KeyFrame Marker and then Copy it.  This is done either by pressing CTL-C or selecting Copy from the Edit Menu.  Cut and Paste work the way it does in most MS software applications.
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Step 2 The Timeline Indicator is moved to 20 seconds and a Paste operation is done.  A Paste may either be done by pressing CTL-V or selecting Paste from the Edit Menu (as in Copy in Step 1).  The Movie has now defined a zoom-in from the first to the second KeyFrame Markers and a zoom-out from the second to the third KeyFrame Markers.  Since the First and last KeyFrame Markers are the same the Image returns to its start position and a loop is completed.
Note:
• The Camera Window and Viewer show the same view of the image as in Example 1 Step 2 which shows the screen after the first KeyFrame Marker has been set.

Step 3 Preview the Movie using the Viewer Window's VCR-like controls.  You will see the Movie zoom-in and then zoom-out to its start.  Create the Flash Movie as in Example 1 by Selecting the Make Flash SWF Movie entry under the File Menu.  See Example 1 Step 4 for details.
Note:
• To make the file continue to loop as shown on the adjacent figure the proper parameters must be set in the published source code that will go on your Web page.  See the Resource sections on Publishing SWF files for more information.



Example 3 will illustrate how to ad a Hold to a movie
Example 3 How to Add Holds to a Movie
A Hold is simply a segment of a movie where the motion is frozen.  This is done with adjacent KeyFrame Markers that have the same value offset by the Hold period in the Timeline.  This example adds a two second Hold to the looping movie created in Example 2.  Next we add two seconds to the end (zoom-in) segment since we shortened it by inserting the Hold two seconds in at the 12 second point. The files associated with this example may be downloaded by clicking on the download icon.  The files are contained in a self extracting .exe so simply click on the downloaded file and the test files and resulting SWF file will be loaded into your selected directory.  Click on the [image: image9.jpg]


Download Icon to download the Example 3 files.
Step 1 Figure 1 shows the screen at the end of Example 2.  The Timeline shows middle KeyFrame Marker at ten seconds into the the movie.  The start KeyFrame Marker was copied to the 20 second point in the Timeline to create a zoom-in / zoom-out effect with equal in and out times of ten seconds (see Example 2).
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Step 2 To create the two second Hold a copy of the KeyFrame Marker is placed at the 12 second point on the Timeline.  See Example 2 Step 2 for a review of Cut and Paste.
After the Duplicate KeyFrame Marker is Pasted to the Timeline the word Hold bounded by indicator lines appears on the time line. The Timeline with the Hold inserted is shown in Figure 2
Note:
• The insertion of the Hold or any Paste operation will not effected the position in the Timeline and the consequential timing of movie.  The effect will shorten the next segment by the time of the insertion.
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Step 3 Because we want the zoom-in and zoom-out periods to be the same we must increase the duration of the final segment by moving the KeyFrame Marker two seconds further along the Timeline.  This is done by moving the mouse cursor over the KeyFrame Marker and then dragging it to the desired position.
Note:
• Dragging a KeyFrame Marker does not effect the position of any other Marker on the Timeline but will effect the timing of the adjacent segments.


 Step 4 Preview the Movie using the Viewer Window's VCR-like controls.  You will see the Movie zoom-in, freeze for two seconds and then zoom-out to its start.  Create the Flash Movie as in Example 1 by Selecting the Make Flash SWF Movie entry under the File Menu.  See Example 1 Step 4 for details.
Note:
• The 22 second movie shown as Figure 4 requires only 27,746 bytes and is being displayed in 320 by 240 pixel resolution.  The movie in Example 3 is two seconds shorter and is 27,709 bytes in size.  The two second Hold only added 35 bytes to the file size!!


Example 4 will show how to create an image rotation.

Example 4 How to Rotate Images
In this example we will show how to rotate images.  First we will do a simple rotation.  Then use Cut and Paste of KeyFrame Markers to to demonstrate how a continuous effect of rotate and rotate back can be made and finally we will show how to create a movie segment in which the image is rotated more than a complete revolution (over 360°).  The files associated with this example may be downloaded by clicking on the download icon.  The files are contained in a self extracting .exe so simply click on the  downloaded file and the test files and resulting SWF file will be loaded into your selected directory.  Click on the Download Icon to download the Example 4 files.  
Step1 The image is loaded and the Camera Window positioned and scaled over the mans face.  A KeyFrame marker is then created to specify the start position of the movie segment  See Example 1.  Figure 1 shows the screen after the start KeyFrame has been created
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Step 2 The KeyFrame Marker is moved to eight seconds in the time line to create an eight second movie segment.  The Camera Window is rotated 45° and the KeyFrame is entered in the Timeline.



Figure 2 shows the screen after the second KeyFrame was entered.  This defines the 45° rotation sequence over the eight second interval.
Step3  Create the Flash Movie as in Example 1 by Selecting the Make Flash SWF Movie entry under the File Menu.  See Example 1 Step 4 for details.  Figure 3 is the exciting result.
In step 4 we will make a rotate loop using the Cut and Paste technique shown in Example 2.


[image: image14.jpg]



Step 5 Create the Flash Movie as in Example 1 by Selecting the Make Flash SWF Movie entry under the File Menu.  See Example 1 Step 4 for details.  Figure 5 is the result.



Example 5 Working With Multiple Images
Example 5 How to Make Movies with Multiple Images
In this example we will make a movie with multiple images.  This is a very simple task with The ImageMatics StillMotion Creator™.  We will add an image to the movie made at the end of Example 1.  We will then do a simple zoom in segment in the movie.  Finally we will make a continuous loop by going back to the beginning of the first segment of the first image.  The files associated with this example may be downloaded by clicking on the download icon.  The files are contained in a self extracting exe so simply click on the  downloaded file and the test files and resulting SWF file will be loaded into your selected directory.  Click on the Download Icon to download the Example 5 files.
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Step 1 We begin by loading the Movie (MPX) file that was created and saved in Example 1 Step 4.  The Movie file is included in the Example 5 Example download as Example5_1.mpx.  Figure 1 shows the the screen after the Movie file has been loaded.
Review Example 1 for how the Movie was created.
Note:
• Note the the Timeline Indicator is at 11 seconds and not sitting on the KeyFrame Marker.  The StillMotion Creator automatically advances the Time cursor one second in anticipation of the next Camera Window move.  We must move the time point back  to the Key Marker to set up the desired position for the loading of the next Image.
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Step 2 As addressed in the Note in Step 1 we first move the Timeline Indictor to the KeyFrame Marker of the end of the Movie segment.   
From the File Menu the Load Picture function is selected.  This presents a standard File Box that provides for the selection of the next Image to load.
Figure 2 shows the screen immediately after the image file Hawaiian .jpg has been selected and loaded.
Note:
• The filename of the new image has been added to the Timeline and a new color is used for the image
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Step 4 A zoom-in is created at 18 seconds.  Play the Movie in the Viewer and you will see the zoom-in on the man's face in the first image.  At the 10 second mark the new image will appear and the movie will now do an 8 second zoom into the Hawaiian's face.
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Step 5 Now we finish the multi-image loop.  Using Load Image we load another copy of the Couples picture at the end KeyFrame Marker shown in Step 4 above.
To create the loop we now must do two Copy and Pastes.  See Example 2 for details on how to do this.  
Figure 5 shows the Copy and Pastes.  First we copy the end KeyFrame Marker from the first segment to the first KeyFrame Marker in the final segment.  This copies the Camera Window position as shown in Figure 5 to the start of the segment.  We then Copy the start KeyFrame from the first segment, move the 8 seconds on the Timeline and then Paste it.  We have now complete the loop.



Step 6  Create the Flash Movie as in Example 1 by Selecting the Make Flash SWF Movie entry under the File Menu.  See Example 1 Step 4 for details.  Figure 6 is the exciting result. We Won't be winning any awards for this one.
The hard break between the images is not recommended style.

In Example 6 we will add fades between the scene changes and demonstrate how to do a fade to black.
Example 6 How to Fade Between Images and How to Fade to Black
In this example we will show how to create fades between images and how to fade to black.  We will use the files in Example 5 to illustrate this.
The files associated with this example may be downloaded by clicking on the download icon.  The files are contained in a self extracting .exe so simply click on the downloaded file and the test files and resulting SWF file will be loaded into your selected directory.  Click on the Download Icon to download the Example 6 [image: image19.jpg]


files.
Step 1 Here is the Show Movie that was created in Example 5.  We will insert cross fades (one picture fades into the other) at each Image load point.  We will make the fades of 4 second durations

Detail[image: image20.jpg]


 The Detail image of the Timeline shows Fade Marker (green triangle) on the Timeline.  A fade is created by grabbing the Fade Marker with the mouse and dragging to the desired length of the transition.




Step 2 In this step we stretch the Fade Indicators to create the transition of the desired time.  The Stage and Viewer images are not altered.
Note
Fade transitions are not visible if the movie is previewed in motion in the Viewer.  To create a transition the viewed image is rendered by creating the appropriate weighted average between the two pictures.  Many PCs will not have the CPU power to show the render in real time. So rather than show a possibly jerky preview the effect is omitted.  The effect may be seen by advancing the Timeline with the "+" and "-" keys.  This provides a slow frame rate but allows for frame accurate viewing and editing of Fades.



Step 3 Create the Flash Movie as in Example 1 by Selecting the Make Flash SWF Movie entry under the File Menu.  See Example 1 Step 4 for details.  Figure 3 is the result. We Won't be winning any awards for this one. Compare this with the Movie created in Example 5 without any transitions.  Adding fades is almost a mandatory step.
Exercise:
Edit the transition times and look at the results long transition times convey a different feel than short ones.  Getting familiar with the the impression of different transition lengths will help you make more compelling Movies.


 

We will continue the discussion of fades and transitions by showing how fade to black or a fade in from black or white can be accomplished.  To do this we must use a clever trick.  We create a small file that is all black and one that is all white.  We have named these (cleverly) in the Example 6 download as black.jpg and white.jpg.  We will create a simple movie that fades-in from white and then fade-outs to black.  This will leave a black box on the screen so we will then show a fade out to white.
Any background can be matched by creating a file to fade to that is the target (or vice versa).
 
 

Step 4 The File White.jpg is loaded in the timeline.  Camera Window is moved to the center of the white image.  As long as all the white is covered the position is not important.  We then created a hold so nothing happens in the segment (see Example 3 on how to create holds) 
Next we loaded Couple.jpg and created a simple zoom-n over the couple's faces. We then loaded the black file, Black.jpg and added a hold.  Figure 4 shows what the screen looked like after the operations where completed.
Example 7 Advanced Effects Example 1
See http://www.imagematics.com/examples/advanced_effects_1.htm for the created animations.
Creating Transitions  In this example we are showing transitions created using pan and zoom manipulations.
Rotate in and out The first transition combines a spin with a zoom out.  We zoomed out approximately five times the width of the image so it appeared to shrink to one fifth its size.
The rotation is one and one half turns in and then out.  That's 540 degrees.
The transition is a half second on each side for the effect.
The easiest way to do this is to right click on the Camera Window, and manually set the width and rotation values. You can then cut and paste the keys to get consistent effects.
Zoom in and Out The second transition uses the same zoom factor and timing as the first.  the difference is that no angle is specified for rotation.  The result is a new effect!
Push We next used the built in fade transition to get to the next image.  Here we cheated to get the push effect.  This image consists of a two pictures.  The second picture being the first in the movie.  We simply pan across the image in a half second for the effect.  Since the SWF file is looping we get the effect of a continuous transition set.  
Below is combined image used in the "push" transition. Any Image editor will let you paste two images together.
You can also paste the images vertically for push Ups and Downs and Push Right or Left.  Four new effects from the same idea.
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Example 7 Advanced Effects Example 2

Creating Transitions  In this example we are showing transitions created using pan and zoom manipulations.
Push Transitions  Creating Push transitions is very simple. To do it you need to create a collage of images as shown below.
In this Example we combine pan and zoom effects with the transitions.
Here are the tricks to doing this well and quickly.
1. Scale all the images to the same size
2. Set the Camera Window Aspect Ration (under Options - Set -Viewer Aspect Ration) to Image (the Aspect of the individual image)
3. Set the Camera Window size to the size of the image.  To do this exactly, right click on the Camera Window and set the Width value to the Width of the Image.  As long as the aspect ration is set to Image the fit will be exact.
4. Use the Camera Window navigation keys to move the camera window across the image. 
· CTL +  →  Right  justifies the Camera Window
[image: image3.jpg]
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